develooper Front page | perl.perl6.users | Postings from August 2022

I can't 'zef uninstall' old versions of modules anymore

Thread Next
From:
Fernando Santagata
Date:
August 9, 2022 11:54
Subject:
I can't 'zef uninstall' old versions of modules anymore
Message ID:
CAJ+jyGjxDhpO0X6mZNBUaJ+ia9_8o-Rwv0B1B9tw6ysv4+62pA@mail.gmail.com
Hello,

I'm trying to uninstall old versions of some modules; it looks like it's
working but in reality it isn't. For example, but it's not limited to just
this module:

$ zef list --installed|grep CBOR
===> Found via /opt/rakudo-pkg/share/perl6/core
===> Found via /home/nando/.raku
CBOR::Simple:ver<0.1.1>:auth<zef:japhb>:api<0>
CBOR::Simple:ver<0.1.2>:auth<zef:japhb>

$ zef uninstall 'CBOR::Simple:ver<0.1.1>:auth<zef:japhb>:api<0>'
===> Uninstalled from /home/nando/.raku
CBOR::Simple:ver<0.1.1>:auth<zef:japhb>:api<0>

$ zef list --installed|grep CBOR
===> Found via /opt/rakudo-pkg/share/perl6/core
===> Found via /home/nando/.raku
CBOR::Simple:ver<0.1.1>:auth<zef:japhb>:api<0>
CBOR::Simple:ver<0.1.2>:auth<zef:japhb>

$ raku --version
Welcome to Rakudo™ v2022.07.
Implementing the Raku® Programming Language v6.d.
Built on MoarVM version 2022.07.
$ zef --version
v0.13.8

It started when I was using Rakudo v2022.06, but I hoped that upgrading to
the next version would solve the problem. Alas, no luck.
All I can say is that when I install a new Rakudo version I always run
cleanup-precomp . I don't know whether this might alter the local zef DB so
that I can't uninstall modules anymore.

Has anyone had the same problem?

-- 
Fernando Santagata

Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About